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Introduction 
 

 
QGIS is an Open Source Geographic Information System (GIS) option.  QGIS is an part 

of the Open Source Geospatial Foundation (OSGeo) and can run on Linux, Unix, Mac 

OSX, Windows and Android and supports numerous vector, raster, and database 

formats and functionalities. 

 

QGIS provides users the functionality to analyze and edit spatial information, in addition 

to map creation. QGIS supports both raster and vector layers; vector data is stored as 

either point, line, or polygon features. Multiple formats of raster images are supported, 

and the software can georeference images. 

 

QGIS supports shapefiles, coverages, personal geodatabases, dxf, MapInfo, PostGIS, 

and other formats.  Web services, including Web Map Service and Web Feature 

Service, are also supported to allow use of data from external sources.  

 

QGIS integrates with other open-source GIS packages, including PostGIS, GRASS 

GIS, and MapServer. Plugins written in Python or C++ extend QGIS's capabilities. 

Plugins can geocode using the Google Geocoding API, perform geoprocessing 

functions similar to those of the standard tools found in ArcGIS, and interface with 

PostgreSQL/PostGIS, SpatiaLite and MySQL databases. 

 

https://qgis.org/en/site/index.html 

https://qgis.org/en/site/index.html
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Tutorial Data 

 
 

1.  Download the data here:   
 

https://drive.google.com/drive/folders/1rWy1f4_XTdIYUhD2OXpSlZDYjeFcnyZF 
 
2.  Save to your C: drive or main drive that you can easily locate 
 
3.  Unzip the folder 
 
4.  You will see two folders VectorData and RasterData 
 
5.  You will also see a file ending in .csv 
 
 
Text Delimited Table 
 
School_Demographics.csv – taken from data.nashville.gov (Nashville Open Data 
Portal). Shows Current student enrollment and demographic information for Metro 
Nashville Public Schools (MNPS) locations. 
 
 
Vector Data (Shapefiles) 

 
Vector data is split into three types: polygon, line (or arc) and point data. Polygons are 
used to represent areas such as the boundary of a city (on a large-scale map), lake, or 
forest.   
 
Polygon features are two dimensional and therefore can be used to measure the area 
and perimeter of a geographic feature. Polygon features are most commonly 
distinguished using either a thematic mapping symbology (color schemes), patterns, or 
in the case of numeric gradation, a color gradation scheme could be used. Line (or arc) 
data is used to represent linear features. Common examples would be rivers, trails, and 
streets.   
 
Line features only have one dimension and therefore can only be used to measure 
length. Point data is most commonly used to represent nonadjacent features and to 
represent discrete data points. Points have zero dimensions; therefore, you can 
measure neither length or area with this dataset. Examples would be schools, points of 
interest, and in the example below, bridge and culvert locations.  Point features are also 
used to represent abstract points. For instance, point locations could represent city 
locations or place names. 
 

https://drive.google.com/drive/folders/1rWy1f4_XTdIYUhD2OXpSlZDYjeFcnyZF
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Polygons:   

School_Districts.shp – taken from data.nashville.gov (Nashville Open Data Portal).  
Contains outlines for Davidson County School Districts. 

 

Buildings.shp - Nashville, Tennessee Building Footprints:  Metropolitan GIS taken from 
koordinates.com 

 

Lines: 

Street_Davidson.shp – Nashville, Tennessee Road Centerlines:  Metropolitan GIS 
taken from koordinates.com 

 

Points: 

Potholes.csv – delimited text file taken from data.nashville.gov (Nashville Open Data 
Portal).  Service requests to hubNashville (311) from residents and visitors.  

 

 

Raster Data 

 
Raster data consists of cells which represent values. The resolution of a raster dataset 
is determined by the size of the cells. For example, a 2.5m resolution DEM, like the 
ones used in this exercise, means that each cell that makes up that raster is 2.5m by 
2.5m. There are two major types of raster data, discrete and continuous. Discrete raster 
data tends to be categorical, whereas continuous raster data is representative of a 
surface.  
 
In this exercise we will look at continuous raster data in the form of digital elevation 
models (DEMs) and digital surface models (DSMs). Data for this exercise was 
downloaded from the TN State data repository at: https://tnmap.tn.gov/.  
 
1730653NE.img  
1730653NW.img 

 

https://tnmap.tn.gov/
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Getting to Know the QGIS Interface 
 

 
 

1. Menu bar: Access to various QGIS features using a standard hierarchical menu. 

2. Toolbars: For interaction with the map, layers, attributes and selections. 

3. Browser Panel: A spatial file browser allowing drag and drop content into the map frame. 

4. Layer Panel: Controls the map layers, their order, and visibility. 

5. Map View: View spatial data 

6. CRS/Coordinate Bar:  Change coordinate reference system on the fly and coordinate 
display 
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Vector Data 

 
 
Adding data 
 
Navigate to VectorData folder in the browser panel (If the browser panel is not visible 
right click the top menu and select the Browser Panel.) 
 
1.  Select Zipcodes.shp and drag to the main view or to the layer panel 
2.  Select School_Demographics.csv and add to the map 
 
 
Projection of Layers and Project 
 
QGIS automatically reads projection information (i.e., the Coordinate Reference System 
[CRS]), if available, from respective layer files. For shapefiles, it relies on the “.prj” file; 
for raster data, it is often embedded in the file. If you load data without built-in projection 
information (e.g., a Delimited Text File), it generally assumes a geographic coordinate 
system (Lat/Long), and uses the World Geodetic Survey 1984 (WGS84) datum, or may 
use the Project CRS the user to specify. It is always a good idea to check that the 
projection information is interpreted correctly by QGIS. 
 
By default, QGIS uses “Projection on the Fly” – for visualization (but not necessarily 
analysis) of multiple layers in different CRSs, they are automatically transformed to be 
in the same coordinate space. 
 
Look to the bottom right corner of your viewer.  Notice the EPSG (coordinate system 

designation code).  To change the CRS of your map, click the world icon  next to the 
designation code.  
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Then select EPSG: 4326 (WGS84) 

 
 
Working with Attribute Tables 
 
1.  Open Attribute Table for School_Demographics.csv by right clicking the layer → 
Open Attribute Table 
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2.  Close attribute table. 
 
3.  Open the attribute table for Zipcodes. 
 

 
 
4.  Note what field is the same in both datasets. 
 
 
Creating a Join 
 
1.  Join the two tables based on their common field to view data from both tables 
simultaneously. Select Zipcodes and right click → Properties → Join  
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Click the green plus button to create a new join. The ‘Add Vector Join’ screen will 
appear. This screen will recognize that join is being performed between the shapefile 
and the School_Demographics table. Select the ZIP field as the Join Field and the and 
the zip field as the Target Field from the shapefile.    

 
 
2. Click Apply to execute the join and then OK to close Layer Properties.  
 
3. Check the attribute table for Zipcodes 

 

Matching field from csv 

Matching field from shape 

Create new join  
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4.  What do you notice?  Scroll across to see more data. 
 
 
Export to New File 
 
1. Right click Zipcodes layer →Save Features As 
 

 
 
2.  Make sure you click the … to locate the data file folder for this exercise and save to 
that folder.   
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3.  Call the new file Joined_Demo.  Make sure the format is ESRI Shapefile and the 
CRS (Coordinate Reference System) remains at EPSG:  4326-WGS84. 
 
 

 
4. Turn off the original zipcodes layer by unchecking it’s box in the layer pane or remove 
it by right clicking the layer and choosing ‘Remove Layer’.  
 
 
Symbolizing by Unique Values 
 
1. Make sure the original zipcodes layer is unchecked (not visible)→ right click 
Join_Demo layer → Properties → 

Symbology  
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2.  Drop down the top menu and change the symbol type to Categorized. Set the 
Column drop down to School D_1 attribute, which corresponds to the type of school. 
Select the Classify button at the bottom left of the toolbox. Select Apply and OK. 

 
 
The new map should look as below, with some potential color variations.  
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Select by Expression  
 
1.  On the top menu bar find the Selection tool, drop down the selection box→Select by 
Expression 
 
 
 

 
 

 
2.  In the Expression box expand the Fields and Values sections to browse for the zip 
value. Click ‘All Unique’ to pull up a list of all the possible zip code options. Create an 
expression that is zip = pick a zipcode → click select features to make your selection.  
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3.  The selection will be highlighted in yellow 
 

 
 
 
Start a new project 
 
1.  Project → New  
 
Clipping 
 
1.    Add Streets_Davidson.shp (drag file) to map view.   
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2.   Add the Potholes.csv as a delimited text layer by choosing Layer → Add Layer → 
Add Delimited Text Layer. 
 

 
 
3.  This will open the ‘Data Source Manger’ window. Browse to your file and choose 
CSV as the format. Make sure to set the x and y fields with Longitude and Latitude 
accordingly and then click Add.  
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The data should add to the map as a point layer, as displayed below.  
 

 
 
3.  Right click the new potholes layer → zoom to layer 
 
 
Clipping 
 
Let’s clip Davidson county street layer (Streets_Davidson)  
There are several ways to clip, but we are going to clip by selection.   
 
1.  Create a new polygon layer to represent the area of interest (AOI) for our study of 
potholes by going to Layer → Create Layer → New Shapefile Layer
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3.  In the ‘New Shapefile Layer’ window, navigate to the vector data folder and name the 
new shapefile Study_Area. Change Geometry type to polygon. Name new field as 
Area. 
 

 
 
 
 
6.  Draw your AOI around where the potholes are.  Right click Study_Area →Toggle 
editing  
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7.  Right click in the tool bar area to open the toolbar and panel options. Check the 
digitizing toolbar to turn it on, and it will appear alongside the other toolbars.  

 
8.  Now select the Add polygon feature tool and draw a rectangle around the area 
where the potholes are.  
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9.  Once you draw your box right click and select ok to complete your drawing. 
 

 
 
 
10.  Turn off editing. → right click Study_Area → turn off editing → Save changes to 
layer 
 
 
Clip Streets to Area of Interest 
 
1.    Select Streets_Davidson layer → Vector → Geoprocessing tools → Clip 
 

 
Call the new clipped layer Clipped_Streets 
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2.  Turn off all layers except Clipped_Streets and Potholes.   
 
Change basic symbology 
 
1.  Right click clipped streets → Properties → Symbology. Select a color that is a good 
representative of a street 

 
 
Note:  You may to need to reorder layers 
 
Creating a Heat Map 
 
1.  Right click Potholes.shp→ Layer Properties → Symbology. Drop down to Heatmap 
symbology type. Change the color ramp to a red ramp and change the opacity 
(transparency) to 50%. 
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The heat map should display as below.  
 

 
 
Select by Location 
Add the Joined_Demo layer back into the map using the ‘Add Data’ button. Change the 
symbology of the Potholes layer back to a single symbol. Examine the distribution of 
potholes within the various zip code boundaries.  
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1. Click on the Joined_Demo Layer in the layers pane to set it as the active layer for 
selections. Click the Identify tool in the main toolbar and use it to identify each of the 
zipcodes in which a pothole falls.  
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2. Use the Select Features by single click or area tool to select the 37212 zipcode 
shape. The selected area will show up in yellow.  

 
 
3. We are going to select all the potholes that are within the 37212 zip code. Confirm 
Joined_Demo is selected → Vector → Research Tools → Select by Location.  

 
 
Select potholes as the layer to select features from, choose intersect as the geometric 
predicate, selected Joined_Demo as the comparing feature, and be sure to check the 
box that says ‘Selected Features Only’ under the comparing feature. This ensures we 
only select potholes in the 37212 zipcode.  
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Creating a Map Layout 
 
The map is complete and now to add the cartography and export it. 
 
1.  Create a new layout by navigating to Main menu → Project → New Project Layout 
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2.  Name the map Layout1 and the screen will open to a new layout with the following 
elements.  
 
 
 

 
 
3.  Draw a new Data Frame in the middle of the layout and add Title, Scale Bar, 
Neatline and North Arrow 
 

Insert Data Frame 

Legend 
Title/Text 

Scale 

Map Layout 

Project/Data View 

Properties/Editing 

Elements 
Export options 

View/Zoom 
North Arrow 
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Raster Data 
 

Adding and Merging Raster Data using Digital Elevation Models (DEM) 
 

Step 1: Add the DEMs to the map. 
Add the 2 DEM raster files to the QGIS project using the ‘Open Data Source Manager’ 
 

 
Choose Raster, and browse the directory to the file path ____ and select the two .img 
files, 1730653NE.img & 1730653NW.img. Select Open and then Add. 
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Your map should have two rasters over the Fort Negley area and Peabody College. 

 
 
Step 2: Merge the two images into one continuous raster DEM.  
Open the ‘Merge’ (GDAL) tool by browsing the Raster tab-> Miscellaneous-> Merge or 
by searching for ‘Merge’ in the Processing Toolbox pane.  
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In the ‘Merge’ tool window, select the two .img files you added to the project as your 
input layers, keep output data type as Float32 (same as the input .img files) and set an 
output location to your local C drive and call this Merged_Nash_DEMs. Run the tool. 
 

 
The output will be automatically added to the map and should looks as follows: 
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Creating a Hillshade 

Step 1: Create a hillshade from the DEM.  
Find the ‘Hillshade’ (GDAL) tool by opening the Raster tab -> Analysis -> Hillshade or 
search for ‘Hillshade’ in the Processing Toolbox pane.  
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Set the input layer as the Merged_Nash_DEMs. Set the output location to your local C 
drive and name the new raster Hillshade_Nash. Leave the other presets and run the 
tool. 
 

 
 
The output will be directly added to the map and should looks like below: 
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Analyzing the DEM 

Step 1: Derive a slope raster from the DEM. 
Find the ‘Slope’ (GDAL) tool by browsing to the Raster tab -> Analysis -> Slope, or 
search for ‘Slope’ in the ‘Processing Toolbox’ pane.  
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Set the Merged_Nash_DEMs as the input raster and set an output location to the 
Raster folder.  Call the new raster Slope_Nash. Leave all other tool parameters the 
same and run.  
 

 
The slope raster will be added to the display and should look like below: 
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Step 2: Find the average slope of the area. 
Right click on the Slope_Nash layer and choose ‘Properties.’ 
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In the Information section of the Properties, look at the statistics to determine the 
average slope.  
 

 
 
 
 
Step 3: Generate an aspect raster.  
Find the ‘Aspect’ (GDAL) tool by opening the Raster tab -> Analysis -> Aspect or search 
for ‘Aspect’ in the Processing Toolbox pane. 
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Choose the Merged_Nash_DEMs as the input layer and set an output location to your 
local C drive. Name the new raster Aspect_Nash. Leave all other presents and run the 
tool. 
 

 
 
The output should be added to the map and should appear as below:  
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Working with Raster Calculator 

Raster calculator is an essential tool for manipulating raster data to create new rasters 
or reclassify rasters. In this example we will use our Nashville DEM and a LiDAR 
derived digital surface model (DSM) to create a canopy height model (CHM).  
Step 1: Add the Nash_DSM to the map from the file path: 
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Step 2: Open the ‘Raster Calculator’ tool by going to the Raster tab -> Raster Calculator 
or search for ‘Raster Calculator’ in the Processing Toolbox pane.  
 

 
 
Step 3: Using the ‘Raster Calculator’ we are going to create a new raster layer that 
represents the CHM. The CHM is calculated as follows CHM=DSM-DEM. In the tool 
window, specify an output location and choose GeoTiff as the Output format. In the 
expression window, write “Nash_DSM@1”- “Merged_Nash_DEMs@1”. The raster 
names have a @1 after them because they all contain only one band. If you wrote the 
expression correctly you should see it say ‘Expression valid’ at the bottom of the tool 
window. Click OK. 
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The new layer should be added to the map and should appear as below: 
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Additional Material 
 

Installation 
 
Recommended:  Download the most recent version of QGIS available, with the most 
recent features, or the most recent Long-Term Release (Stable), which is designed to 
be maintained with bug-fixes and such for the next three release cycles. Long term 
releases might not have the newest features found in the most recent version, but focus 
is broader stability across time.  
 

 
 
For Windows users: 
 
Download and run the standalone installer, available here: 
https://qgis.org/en/site/forusers/download.html (QGIS Standalone Installer Version 
3.4).  Choose 64 of 32 bit based on your computer. 
 
For Mac OS users: 
 
Download and run the standalone installer, available here: 
https://qgis.org/en/site/forusers/download.html  (QGIS Standalone Installer Version 
3.4).  Choose 64 of 32 bit based on your computer. 
 
For Linux Users: 
 
Follow instructions provided here: 
https://qgis.org/en/site/forusers/alldownloads.html#linux. 
  

https://qgis.org/en/site/forusers/download.html
https://qgis.org/en/site/forusers/download.html
https://qgis.org/en/site/forusers/alldownloads.html#linux
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Add a Background Layer 
 
When we import spatial data, we often like to visualize them over some sort of 

background layer, such as aerial imagery, or a simple map. This allows us to 

identify if layers are being displayed in approximately the right location, and it can 

help with some preliminary interpretation of data. For this exercise, we will utilize 

the QuickMapServices Plugin. 

• Click on “Web” from the menu bar at top, navigate to “QuickMapServices Plugin” 

-> “Search QMS”; the search panel for this plugin will appear. 

• By default, some Google layers will be available to load. If you click “Add” 

while selecting any specific layer, the newly added background layers will 

appear as the bottom-most layer. 

o You can also use the Search bar to find map services that 

are made available in this plug-in (e.g., search for Google, 

Bing, or Open Street Map). 

 
Changing Projections (CRS) 
 
For many operations it is necessary to have all layers in the same CRS; even if it is not 

necessary, it can help speed-up processing considerably. The DEM has elevation in 

meters, according the layer’s metadata, and it is in a geographic projection (Lat/Long, 

NAD83). However, for computing some derivatives of elevation such as Slope, it is 

helpful to have the horizontal units the same as the units for elevation. Thus, we will 

work in a projection that is also defined in meters, the Albers Equal Area Projection. 

This projection may cause some distortion in shape, but maintains accurate area 

measurements. This is just a demonstration, and in doing your own work, it is important 

to consider how spatial distortions may manifest in different projections. 

The steps for converting the CRS of raster and vector layers are somewhat different. 

Furthermore, when converting the CRS of raster layers, it is important to think about 

how resampling may cause distortion. 


